System performance incident
Incident Report for PracticePanther
Resolved
We were able to identify the root cause of the issues that have been affecting the speed and performance of PracticePanther.

It took longer then normal to resolve, as our diagnostic tools did not detect any abnormalities or provide any detailed info to the root cause of the issue.

The issues were related to our last update from this past weekend. One heavily requested feature that enabled sorting contacts and matters by custom fields ended up causing the downtime and server degradation. We ended up reverting the application code back to the previous stable release without this new feature which has resolved the issue and brought performance back to normal.

As a software company we constantly strive to improve our product and take pride in the frequency of our updates. Unfortunately sometimes issues can make it to production that we were unable to identify before the final release. We have implemented new procedures, new QA tools, and new analytics to catch these issues before they come up again.

We thank you for your continued feedback and feature requests, and aim to deliver the best and easiest to use case management software for years to come.
Posted Oct 17, 2017 - 13:32 EDT
Investigating
Some users are experiencing slow response time when using the app. We are still investigating this issue and are working closely with Microsoft's engineers, which is where our application is deployed. Our entire development team is working hard to get this resolved as soon as possible. We will post updates here as we make progress. We apologize for any inconvenience this may have caused and are doing our best to get this resolved ASAP.
Posted Oct 17, 2017 - 11:08 EDT