Degraded Performance
Incident Report for PracticePanther
Resolved
All services should be normal for all PracticePanther users. Thank you for your patience while we resolved this.
Posted Jan 30, 2020 - 14:16 EST
Monitoring
We have applied a fix and are watching normal operation return to our customers. We will keep monitoring this until all slowness has subsided.
Posted Jan 30, 2020 - 11:12 EST
Investigating
We are currently investigating an issue causing degraded performance on app.practicepanther.com, such as slow load times. You may check back here periodically as we will post updates when further information is obtained.

Thank you for your patience as we work to resolve this.
Posted Jan 30, 2020 - 10:36 EST
This incident affected: PracticePanther.