Some PracticePanther users may experience slowness while using the app
Incident Report for PracticePanther
Resolved
All the diagnostics services have finished running. All systems are back to normal. We apologize for the inconvenience.
Posted Oct 16, 2017 - 22:25 EDT
Monitoring
We are currently running diagnostic tests on our servers to get more information about today's issues which may cause degraded performance for the next 10 minutes. We apologize for the inconvenience and are working hard to resolve this as soon as possible.
Posted Oct 16, 2017 - 22:19 EDT