Degraded Performance
Incident Report for PracticePanther
Resolved
This incident has been resolved.
Posted Jun 23, 2020 - 15:57 EDT
Monitoring
Our engineers in conjunction with Microsoft team members were able to apply a fix to the cause of the slowness, and site performance seems to be returning to normal levels. We will continue monitoring the slowness to ensure healthy operation.

Thank you for your patience during this event.
Posted Jun 23, 2020 - 15:29 EDT
Investigating
We are currently investigating a higher than average load on our web servers causing degraded performance on app.practicepanther.com, such as slow load times. You may check back here periodically as we will post updates when further information is obtained.

Thank you for your patience as we work to resolve this.
Posted Jun 23, 2020 - 14:49 EDT
This incident affected: PracticePanther.