Degraded Performance
Incident Report for PracticePanther
Resolved
Our engineering team has applied a fix that stabilized our services. We are sorry for the inconvenience this may have caused.
Posted Feb 09, 2022 - 18:30 EST
Investigating
Some users may be experiencing slowness with PracticePanther's web app at this time. The issue is impacting navigation, creation and editing of items. Our team is looking into it and we'll follow up with more updates in 30 minutes.
Posted Feb 09, 2022 - 17:00 EST
This incident affected: PracticePanther.